Announcement

Collapse
No announcement yet.

OG Meta Title Error & Images not loading

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • OG Meta Title Error & Images not loading

    Hello,

    Just trying the free trial and so far I am really happy with this plugin.
    However I'm having 2 issues.

    The first is the OG Meta Title, it is always showing as "520: Web server is returning an unknown error"

    The second issue is when creating a post, the image populates for one second then it's gone, I can click on "Change Image" and set it manually however this is going to become a bit annyoing, the strange thing is this worked fine until I started the premium trial?

    I think its easier if I show you the problem so please see below

    Click image for larger version

Name:	Animation.gif
Views:	34
Size:	128.5 KB
ID:	2681
    If I can get this resolved then you've got yourself a paying customer for life

    Kind regards!

  • #2
    I've attached a gif of the problem here: https://gifyu.com/image/58pJ

    Also might be worth mentioning I'm using Siteground as my WP host, We also have cloudfare enabled.
    Attached Files
    Last edited by eveloko; 05-08-2021, 07:12 PM.

    Comment


    • #3
      Hello,

      Thank you so much for reaching out and thanks for your interest in Blog2Social.

      It is possible that a “520:Web server is returning an unknown error” notification is caused by an individualized WordPress website environment or server-sided settings and configurations.

      You can read more about it at:
      https://wiki-tech.net/errors/0x/Error%20520/

      In general, you should make sure to avoid limiting the Blog2Social plugin with external WordPress optimization or security plugins that are active in your WordPress installation.

      One possible solution is to adjust your settings within these plugins or disable them temporarily in order to allow Blog2Social to work as intended.

      Please note that this behavior is no general issue within Blog2Social and you should consider hiring a WordPress expert in order to help you fix the occurring behavior in your WordPress installation.

      Please be so kind as to try to adjust or disable these settings/plugins and retry to share a post with Blog2Social.
      Propper access is often blocked by installed security plugins or additional firewalls on the server-side as well.

      You may try to unblock our IPs:
      IPv4: 176.28.35.48
      IPv6: 2a01:488:42:1000:b01c:2330:2:7557

      Please be so kind as to try to whitelist your own server IP as well in order to allow automatic curl processes.

      Please note that the access to your site to read the Open Graph parameters by social media networks or other established connections also could be blocked out by your external configuration.

      In general, it is not recommended to block out entire countries. This often limits the functionality within WordPress plugins.
      If you suffer from bot attacks you should also consider involving a WordPress expert for your individual needs securing your website.

      It is also possible that your website was not reachable when the social media network tried to receive the required data to publish your posts.

      One possible issue could be that your website seems to suffer from timeouts while sharing content. Make sure to check the Blog2Social system requirements for “Max execution time”: System requirements for installing Blog2Social

      It would be awesome if you could try to enable the “Legacy mode” within the Blog2Social settings to optimize the sharing process on your WordPress installation.

      An overload or lack of server capacity can cause the Blog2Social dashboard to freeze or not load at all. If your website is hosted on a server with low server capacity, you can turn on the Blog2Social Legacy Mode to reduce server load.

      In Legacy Mode, the plugin will load contents one after the other (asynchronous loading) instead of loading all at once.
      Some web hosting services also limit the number of outgoing connections. In this case, the Legacy Mode makes sure that connections to your social media accounts are loaded successively.

      To activate Legacy Mode, go to “Blog2Social -> Settings -> General -> System” and tick the box saying “activate Legacy Mode”.

      You can test your PageSpeed scores with the Google page speed checker by entering the URL of your website URL on the following page: https://developers.google.com/speed/pagespeed/insights

      Thank you for your understanding.

      Please let me know if you have any other questions or suggestions about Blog2Social.
      I will gladly support you further.

      Best regards
      Alexander

      Comment


      • #4
        Hi evoloko & Support,

        I have exactly the same issue in exactly the same environment (Siteground-Cloudflare-WP).

        evoloko, have you been able to sort it out?

        Thanks!

        Comment


        • #5
          Hello,

          Thank you so much for reaching out and thanks for describing your request
          Would you please be so kind as to answer a few short questions so we could look further into this for you?

          Are you currently facing a "520: Web server is returning an unknown error" error notification in your Open Graph generated preview?

          Or are you facing an issue while changing the social media post image?
          Please be so kind as to attach a screenshot showing the individual situation in your WordPress environment.

          Besides that, would you please be so kind as to provide us with the generated troubleshooting-tool .txt Log file so I could look further into this for you?

          You will find the Troubleshooting-Tool by following this path:
          Your WordPress installation -> Blog2Social -> Help & Support -> Troubleshooting-Tool

          Please also be so kind as to provide us with a screenshot showing the individual conflicts, if available in the overview.
          You can send me these files and information via a private message in the community, in order to protect your privacy.

          Thank you for your understanding.
          I am looking forward to your reply.

          Best regards
          Alexander

          Comment

          Working...
          X