Announcement

Collapse
No announcement yet.

B2S says Heartbeats not enabled but it is and scheduler not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • B2S says Heartbeats not enabled but it is and scheduler not working

    B2S says heartbeats not enabled but it is and scheduler is not working consistently. See the Full Issue Text.pdf attachment for the full issue description. Need chat support.
    Attached Files

  • #2
    Hello Rhonda,

    Thank you so much for reaching out and thank you for providing these details as well as the corresponding screenshot pdf documents.


    If the scheduler is not working consistently and the troubleshooter screen is complaining that heartbeats are not enabled, this likely a possible reason for this. Please be so kind as to answer a few short questions so I would be able to look further into this for you.

    Do you have any other active firewall or security plugin active in your WordPress installation?

    Have you generated the troubleshooting tool report of Blog2Social?

    If not you can easily find it by following this path to generate it:
    Your WordPress installation -> Blog2Social -> Help & Support-> Troubleshooting-Tool

    Please be so kind and send me the complete .txt document of this report via a private message in the community.

    WordPress is working with heartbeats by default. Of course, you can deactivate or regulate heartbeats with plugins such as "Heartbeats Control" or "WP Rocket" or similar. However, deactivating heartbeats prevents the background tasks of WordPress and Blog2Social from being executed properly.

    For instance, sharing posts automatically in your social media is blocked by the plugin "Heartbeat Control" or similar. Please make sure that these plugins are not set to "disable everywhere".

    It might occur that no heartbeat is sent between the time you publish your post on your blog and logging out if heartbeats are limited with plugins like "WP Rocket". If you log in again, a heartbeat will be executed directly, which will send the data.

    Therefore, please do not limit heartbeats to make sure that your posts are shared automatically on your social media.

    However, if you want to regulate heartbeats anyway, you can do so without selectively deactivating the plugin: http://www.wpbeginner.com/plugins/ho...-in-wordpress/

    Please note: Some Hosting services such as WPEngine restrict heartbeats by default. If you encounter the following message and have not actively restricted heartbeats, please contact your hosting service and ask them to enable heartbeats for you. It could also help to ask your hosting provider to double-check the configuration since you have mentioned that you have a visible conflict in the troubleshooting tool.


    Furthermore, you have mentioned that an Instagram post failed to be shared. Blog2Social has a specific section for notifications, if a post fails to be shared or encounters an issue you will see an entry in the notification list of Blog2Social.

    You can find it by following this path:
    Your WordPress installation -> Blog2Social -> Site & Blog Content -> Notifications -> Details

    Please be so kind and screenshot that view if you have any entry in that list.

    The following instructions will guide you through the process about how to solve common issues related to sharing your content on Instagram:

    Solutions: Why does Instagram not publish my post/text?
    Connecting and posting on Instagram - Troubleshooting checklist

    If these guides and instructions do not help like expected some more details on what you have tried and if you receive any error message would be awesome to be able to look further into this for you.


    I am looking forward to your reply.


    Best regards

    Alexander
    Last edited by Blog2Social Support; 09-08-2020, 01:13 PM.

    Comment


    • #3
      Here are the documents you requested.

      FYI, WP Engine has already enabled Heartbeats for all non-editing pages, which is the only thing that is by default disabled by them. They also changed the heartbeat throttle interval from 15 to 60 to try to help. The scheduler for Blog2Social still doesn't work.
      Attached Files

      Comment


      • #4
        Hello Rhonda,

        Thank you so much for reaching out and thank you for providing the requested screenshot.

        As far as I noticed you should re-authorize your social media connection for Instagram.

        You can do that easily by following these steps:
        1. Follow this path: Your WordPress installation -> Blog2Social -> Networks
        2. Search for InstagramClick on the second icon (refresh icon) on the right-hand side of the entries in the list.
        3. Please have a look at the following screenshot as a reference:

        Furthermore, please be so kind as to let me know if you were able to share a post with Blog2Social in the past.

        Since, you faced the notification that Instagram, Facebook, and Twitter could not publish your post. The following step-by-step guide will show you how to solve common issues related to this notification:

        Solutions: Why does Instagram not publish my post/text?

        Would you please be so kind as to provide us with links to posts that could not be shared? You can send me these URLs via a private message in the community to protect your privacy.


        I am looking forward to your reply.


        Best regards

        Alexander

        Comment

        Working...
        X