No announcement yet.

All Scheduled Posts have stopped posting

  • Filter
  • Time
  • Show
Clear All
new posts

  • All Scheduled Posts have stopped posting

    As of late last week, all of our scheduled posts have failed to post (including facebook page/profile/groups, instagram (business), twitter, linkedin... all social media platforms). We've never had this problem before. All social media connections seem fine. Support text attached.

    Short-term question: is there a work-around to immediately post scheduled posts when they aren't triggered?
    Long-term: what's going on that's preventing the scheduled posts from posting?
    Attached Files

  • #2

    Thank you for reaching out.

    Since the scheduled post has been shared till last week, may I ask you if you changed anything in the settings? Or did you install a new plugin/theme?

    Furthermore, would you be so kind and check the following points?
    1. Please go to "Blog2Social -> Site & Blog Content -> Scheduled posts" and check if the scheduled posts are listed here and if there is a notification by clicking on "Details" next to the post. Please send me a screenshot of this notification.
    2. Pleade go to "Blog2Social -> Site & Blog Conten -> Notifications" and check if you got any message there by clicking on "Details" next to the post. Please send me a screenshot of this notification.

    In the txt.file I have seen that there is a plugin warning regarding Wordfence Security. Please be so kind to deactivate this plugin and try to schedule and share a post again.

    When I know where the scheduled posts, that have not been shared, are listed and what the issue is, I will of course explain how you can re-share the posts with a few clicks.

    I am looking forward to your answer.

    Thanks and kind regards.



    • #3
      I think I discovered the problem... a performance enhancing plugin disabled wordpress heartbeat... I re-enabled that and within about 30 minutes the scheduled posts were posted! I'll follow the other steps you outlined should I have another issue.

      One other odd issue I encountered this week - I added some new social media accounts and collections. After doing this, my autopost setting changed to another collection (I never accessed the autopost settings). It seems to be figured correctly now, but having these changes occur without my input is a bit concerning.


      • #4

        Thanks for your feedback. Great to hear that it’s working for you now.

        May I ask you which plugin disabled the WordPress heartbeats?

        Please also let me know if the network collection in your auto-post settings changes to another collection.

        Best regards



        • #5
          SG Optimizer was the culprit. The setting to selectively disable heartbeat was turned on previously and didn't seem to affect the postings... but maybe something changed after a recent upgrade.